This project is read-only.

Install issue

Jan 20, 2008 at 2:17 PM
I got the lastest code from source control, and I had issues. First I tried compiling and just debugging it, but that didn't work. (I found out later this was because there wasn't a plugins directory in my bin\Debug.) So then I tried building the setup project and installing that. When I tried running it after the install, it immediately failed.

The issue, it turns out, is simple (though it took a while to track down). When I built the solution and then the setup project, Visual Studio put the Cropper.Extensibility dll in the plugins directory. That dependency isn't pre-detected in the setup project in source control. So what I had to do was modify the properties of that dll to go to the Application Folder. After a rebuild and install, the app works fine.

I've made some other changes locally. I added log4net logging to the catches so I can easily uncover any future issues, and I changed the reflection that causes the failure with Cropper.Extensibility in the plugins directory. I agree that more documentation would be handy.

Is anyone else seeing similar issues? Is anyone maintaining the code? Can we resolve them and check them in?
Nov 26, 2009 at 9:53 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Nov 26, 2009 at 9:58 AM

I made a work item for the initial problem (not having any output formats in the plugins directory when building and running from source).

Currently, the installation project has the Extensibility assembly in the Application Folder.


I was recently added to the project and have been working on the code.

Patches are always welcome.