This project is read-only.

try to run your last source code in VS2008 under win 7 64bits

Jan 26, 2012 at 3:51 AM

Hi Terry,



I'm having a strange problem. I've downloaded your lasted source code and try to run on my vs2008 under an Windows 7 with 64bits...



It's compiling ok. but when I run it's saying that's not a valid win32 aplication...

I Could not understand why this is happing because the setup build 1.9.4 is working all right!!!

I've already tried to download older versions and the problem is the same...
I've copied the error bellow to show you the problem, the second line is in portuguese but translating means:
 Message=" not valid win32 aplication (Exception HRESULT: 0x800700C1)"




System.BadImageFormatException was unhandled
Message=" não é um aplicativo Win32 válido. (Exceção de HRESULT: 0x800700C1)"
Source="Cropper"
StackTrace:
em Fusion8.Cropper.Program.Main()
em System.AppDomain._nExecuteAssembly(Assembly assembly, String[] args)
em Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
em System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
em System.Threading.ThreadHelper.ThreadStart()
InnerException:


could you help me to find out this problem?

Feb 24, 2012 at 9:48 PM
Edited Feb 24, 2012 at 10:13 PM

Cropper is dependent on a 32-bit assembly and has to be compiled as x86. I removed the other platform options so this shouldn't be an issue going forward. The change is in http://cropper.codeplex.com/SourceControl/changeset/changes/86918. Also, it looks like Brian updated the project to Visual Studio 2010.

If you would like to use an older version of the code, set the platform to x86 and you should be good.