This project is read-only.

can't output, get error message about no outputs

Dec 1, 2009 at 5:09 PM

Great tool, thank you.  But after the upgrade, I'm having a small problem, I can't get any screen caps.  I'm getting this error message once I try to do the capture.

"No output plug-in found.  Verify you have plug-ins in the plug-in directory and choose one from the output menu."

My problem is there are the default plugins in the directory but the Output menu doesn't have the right arrow to select anything.  Is this part of the upgrade?

Thanks.

 

Dec 1, 2009 at 5:34 PM

On a fresh install (where Cropper hasn't been ran before) I get "No outputs loaded." as the output format. However, I do get the list of available output formats under the Output menu.

 

Was this on a machine that previously hadn't run Cropper? Do you have any other formats in the plugins directory?

Dec 1, 2009 at 5:50 PM
Edited Dec 1, 2009 at 5:56 PM

Hi Terry, I believe I found out what's going on.  But to answer your question first, I had a previous version of Cropper installed and no other custom (ie extra) plugins.  I just had/have what's in the default install. 

What I found out was when the ParsePluginDirectory() method is called, it's looking into c:\Documents and Settings\MyUserName\plugins which obviously is incorrect when I think it should have a 'Cropper' in before the plugins.  This is confirmed when I actually do drop in a plugins directory in there, everything works just fine.  I believe the actual culprit.  I got the code and put a couple of MessageBox.Show() in there to poke around a bit (hope you don't mind?).  It looks like this if the main issue.

string 

directory = (Path.Combine( Environment.CurrentDirectory, PluginFolder ));

I think it should a more direct reference instead of the CurrentDirectory.  Why is that?  Cause when I  use my MS Keyboard 4000 and I have the custom keys along the top to fire up Cropper to get a screen cap quickly, the current directory is obviously the wrong one. 

A work around (and confirms the directory reference) is I created a shortcut to the Cropper.exe and then used THAT shortcut to launch cropper from the MS Keyboard 4000, since shortcuts have a starting directory (which I think sets the current directory), it all worked out.

Hope this helps.  Not sure if this is a fix or not but hope it helps.

Dec 2, 2009 at 2:21 AM

I wrote a unit test for a an issue described in Discussion 29390. In order to get the test runner to pickup the plugins I changed the line to use the Environment property rather than the Application.

I reverted the line and repackaged the release, so you'll need to re-download the 1.9.3 zip. I'll make sure this scenario works correctly from now on, sorry for the trouble Peter.

Dec 2, 2009 at 2:52 PM

re trouble

Oh sorry, didn't mean to come across like that, Cropper's a FANTASTIC TOOL and it works GREAT!  (one of those is easy, both nearly impossible, go figure?! :>) 

re Discussion 29390

I tried to find that reference but I guess I'm new to CodePlex cause I'm not able to locate that discussion/issue.  Any tips?

re Environment vs Application

hhhmmmmm You were originally doing it, either one seems like a bit of a compromise on the fringe/edge cases (like mine, DOH!).  Maybe there's a way or a requirement to do both?  Can you use the Environment one to check to see if it's not the root of the Documents and Settings?  If so, then use Application?  Or visa versa?  Not sure, but it seems like you've already tried to think about both use cases.  I certainly don't want to be that customer "who screams the loudest!" to get my way.  I think the right solution might lie in using both "magic path" constants.

Thanks again for a great tool!  Keep up the good work!

Dec 2, 2009 at 5:05 PM
Edited Dec 2, 2009 at 5:06 PM

I apologize, the trouble comment was a little tongue-in-cheek. I never thought to run Cropper from my favorite buttons on my keyboard as I never use them. I felt bad because at the time I wasn't sure why it used Application.StartupPath and thought that Environment.CurrentDirectory would be fine.

The URL for the discussion http://cropper.codeplex.com/Thread/View.aspx?ThreadId=29390

I tried a few ideas last night before I reverted the change to get the test to work and maintain the launch scenario, but of course it didn't work. I'll figure something out to down the road, I just wanted to get you back up and running.

 

Thanks again for the feedback.

Dec 2, 2009 at 7:17 PM

I downloaded the latest, build a release build, copied it over and worked like a charm!  Very cool.  THanks for the update!

re tongue in cheek

So you have one of those MS ergonimic 4000 keyboards too?  Just in case you didn't know, this might be useful (http://www.pchenry.com/Home/tabid/36/EntryID/77/Default.aspx).

re 29390 link

AH!  I see now, it's just another forum posting/question?  I originated back in June, thanks for the heads up!

Have a good one! :> 

PS  I have my Favourite keys mapped to VS, SS Management Studio, Cropper, Dev and Documents.  I thought they would be a novelty when I first got my keyboard but now it's a must have for any new keyboard, that's how much I use them!